Unable to upgrade ilvl gear at npcs

#1 - June 13, 2024, 1:06 a.m.
Blizzard Post

No clue what is going on, but I am unable to upgrade any of my gear on any of my toons in Val. I tried both npcs in town, and they are not allowing me to upgrade my gear (they showed my gear as blacked out and won’t even drag the gear into the box). And I get a prompt saying, “This item cannot be upgraded,” even though it’s not fully capped.

What’s weird is when I hopped on one of my alts, the npc is saying I can upgrade gear from last season! Yet when I go to upgrade it just to test it…it’s not upgrading, lol.
I have ample crests and stones so that’s definitely not the issue. I tried restarting the game, checked my addons- nothing.

Anyone else had this issue or know how to fix it?

Forum Avatar
Community Manager
#34 - June 13, 2024, 2:24 a.m.
Blizzard Post

Thank you for your reports. We’re working on a fix for the upgrade issue that will require realm restarts. We expect restarts to happen tonight for EU realms and tomorrow morning for US realms.