Mardiva's Laboratory, quest won't complete after activating device

#1 - Oct. 20, 2019, 1:37 p.m.
Blizzard Post

I completed the first quest with choosing a crystal to activate (although after watching a video guide, it didn’t look like that when I activated it, with “flames” appearing), then went with a friend to do some WQs while he had time for it, then came back later to take next quest in Mardiva’s Laboratory questline where I have to activate the device. I clicked on ‘activate’ and enemy appeared, which I killed.
But I can’t complete the quest, because no matter how many times I click on ‘activate’ device it doesn’t activate it.
I have tried to reload ui several times, tried to abandon and retake quest several times.

Forum Avatar
Customer Support
#2 - Oct. 20, 2019, 1:47 p.m.
Blizzard Post

Hi, Vendithià! o/

If I understand this correctly, you activated the device, and killed the elemental appearing, but the quest didn’t advance, and is still asking you to activate the device, right?

If this is the case, I would simply abandon the quest and start it again. You’ll have to kill the elemental again, but it should work.

What probably happened is that at some point, while playing with your friend, your group became a raid group. Most quests can’t be completed in raid groups, which can cause these kinds of issues.