Karazhan chess event loot bug

#1 - July 6, 2019, 10:56 p.m.
Blizzard Post

Karazhan chess event loot is broken like hell now. :angry:
If you win the event (defeat boss) get this “message”


Like i joined the raid after boss kill. Can’t use the chest (no cogwheel) and can’t restart the event also. Still can progress to the last boss but that’s all. Tried with multiple chars with the same result. Tried without any addon with the same result.
Just farming transmogs but without loot this is a LITTLE bit frustrating.
Anyone know a solution or workaround?

PS: My first post here. What is this “no link allowed” thing???

Forum Avatar
Forum Ambassador
#24 - Oct. 18, 2019, 3:37 p.m.
Blizzard Post

Hello everyone!

We are aware of the issue and are actively working on fixing it. Apologies for any frustration this may be causing you.

Forum Avatar
Forum Ambassador
#30 - Nov. 22, 2019, 9:53 p.m.
Blizzard Post

I can certainly understand the frustration with this one with how long it’s gone on.
We appreciate all the reports and updates, topics like this as well as the bug reports and tickets sent in too. These are all something that the team use to measure impact of a bug or game issue.

Some issues are not hotfixable and require a Patch to resolve them though.
This one is definitely on the WoW teams radar and something they are working to fix as soon as they can.

I’m still hoping to get the leather shoulders… maybe next time I clear Karazhan :smiley: