Failed to open archive interface.MPQ

#0 - April 19, 2010, 9:59 p.m.
Blizzard Post
ok, i have a mac book pro and im in college so i cant redownload wow. when i was in class i moved the wow exe onto the desktop and didnt realize that would do anything. Then it said "failed to open archive interface.MPQ when i tried to open the game. i looked through the problems and saw that i needed the common MPQ and i found it. i moved it around a bit and kept trying to launch the game. Then finally i put it under Data and moved the launcher and the wow exe to the wow folder. then i launched the game and i thought it was working until it crashed and asked me to write what happend. i tried moving the common mpq and the common-2.MPQ around and the only time it actually launches is when it is under Data, otherwise it just says "failed to open archive interface.MPQ" please reply soon!
#1 - April 19, 2010, 10:14 p.m.
Blizzard Post

The common.mpq and common2.mpq should be in the data folder along with a few other .mpq files. These files include patch.mpq, patch2.mpq, patch3.mpq, expansion.mpq, and lichking.mpq. Keep in mind the lichking.mpq will be there only if you have the Lich King installed.

The failed to open archive interface.mpq message usually indicates missing data that the game needs to run. If this message keeps coming up you will have to uninstall and reinstall. If you need to reinstall and you have the Lich King disk, you can use that to install all three versions. This will also leave you at patch version 3.0.1. Then you will just need to patch from that version up.

Here's how to do a complete uninstall in Macs:

1. Navigate to your World of Warcraft folder. Move the entire folder to the trash.
2. Go to your Macintosh HD/Users/Shared folder and move the Blizzard folder to the Trash
3. Go to your Macintosh HD/Users/your username/Library/Preferences and delete any files associated with WOW:
(some files may not appear due to non-use)

- com.blizzard.downloader.plist
- com.blizzard.Downloader.prefs
- com.blizzard.errorreporter.plist
- com.blizzard.Installer.plist
- com.blizzard.launcher.plist
- com.blizzard.World of Warcraft.prefs
- com.blizzard.World of Warcraft.survey.prefs

4. empty Trash

If the issue persists you can post on our Mac forums or you can email Mac support at
#6 - April 20, 2010, 1:04 p.m.
Blizzard Post
Hello Lovestosmooh,

Those files should be in the Data Æ’older, but more importantly you need to make sure the game can Read those files, so let's reset the permissions to make sure that's working:

1. Select the World of Warcraft folder
2. press Command + i
3. in the World of Warcraft Info box, go to the Sharing & Permissions section
4. click on the lock and unlock it
5. make sure you have Read & Write permissions
6. click on the Burst icon ( cog wheel ) and select Apply to enclosed items**

** If using Mac OS 10.4.11, just click on the Apply to Enclosed items button.

Now start the game using the World of Warcraft

Side Note: Davidedl is a PC tech, and though he had the right intentions, he's still using PC logic.