Can't download PTR

#1 - Sept. 10, 2014, 6:16 p.m.
Blizzard Post
i tried to install the PTR ( i have deleted it before in patch 5.4.8). It started to patch something but right before"playable" step it got stuck to 9.21GB. I waited something like 15-20 mins and then it showed this error "Failed to Download Files from". I tried everything + reinstall my bnet app. What should i do. Can anyone help me. Its still with the MOP background and logo if thats important.
Thanks alot!
Forum Avatar
Quality Assurance
#2 - Sept. 11, 2014, 4:49 a.m.
Blizzard Post
Hi Triatsonbg,

It would be really helpful if you could send us some logs to help us diagnosis what's going on. Here's what you'll need to do to send us information:

    1. Download LogGoblin.exe.
    2. Run LogGoblin.exe and give it a few minutes to gather your logs.
    3. After it finishes collecting your logs, press Enter to close the program.
    4. A zip file named BlizzardLogs-[YYYY-MM-DD].[HHMMSS].zip, which contains all of your log files, was created in the same location as LogGoblin.exe.

Once the .zip file is created, please email it to with the title [WoW] [PTR] [Unable to Install] [14277498454].

Forum Avatar
Quality Assurance
#3 - Sept. 12, 2014, 5:38 p.m.
Blizzard Post
Thanks for the logs everybody!

We've deployed a new backend change to the app that should hopefully resolve this issue for you. In order to pickup the changes, please do the following.

  • Close your App.
  • Wait at least 15 seconds for background process to close.
  • Re-launch your App.
  • If your app prompts you to restart to pickup an update, please do so.
  • Once your app has re-launched, attempt to install the PTR again.
  • Your download should no longer get stuck at ~9GB remaining.

    If you're still getting stuck, click the Battlenet icon (Blue swirly thing) in the top left corner. Select Settings, and then click "About". Check to make sure that Agent Version has updated to If it reads an older number, please restart your client and re-launch it.